#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\.select \h* ( \( (?> [^()]++ | (?1) )* \) )"
Local $sString = ".select( foo(bar()) ) abcd" & @CRLF & _
".select( foo() )" & @CRLF & _
".select()" & @CRLF & _
"" & @CRLF & _
".asdf( foo(bar()) )" & @CRLF & _
".asdf( foo() )" & @CRLF & _
".asdf()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")