import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.select \\h* ( \\( (?> [^()]++ | (?1) )* \\) )";
final String string = ".select( foo(bar()) ) abcd\n"
+ ".select( foo() )\n"
+ ".select()\n\n"
+ ".asdf( foo(bar()) )\n"
+ ".asdf( foo() )\n"
+ ".asdf()";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}