using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.select \h* ( \( (?> [^()]++ | (?1) )* \) )";
string input = @".select( foo(bar()) ) abcd
.select( foo() )
.select()
.asdf( foo(bar()) )
.asdf( foo() )
.asdf()";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}