package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+),(.+),(\d+)$`)
var str = `732,ELA.1,10
`
var substitution = "DELETE FROM `cbl_student_competencies` WHERE StudentID = $1 and CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2") and Level = $3;"
fmt.Println(re.ReplaceAllString(str, substitution))
}