$re = '/^(\d+),(.+),(\d+)$/m';
$str = '732,ELA.1,10
';
$subst = "DELETE FROM `cbl_student_competencies` WHERE StudentID = $1 and CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = \"$2\") and Level = $3;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;