import Foundation
let pattern = #"^(\d+),(.+),(\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
732,ELA.1,10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"DELETE FROM `cbl_student_competencies` WHERE StudentID = $1 and CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2") and Level = $3;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)