use strict;
my $str = '732,ELA.1,10
';
my $regex = qr/^(\d+),(.+),(\d+)$/mp;
my $subst = 'DELETE FROM `cbl_student_competencies` WHERE StudentID = $1 and CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2") and Level = $3;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";