#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?!\d)(?! ?(?:red|green)).*(\bwarehouse\b)"
Local $sString = "123 warehouse" & @CRLF & _
"123 token warehouse." & @CRLF & _
"123token token abc123; etc. - warehouse " & @CRLF & _
"123abdc token abc green warehouse " & @CRLF & _
"" & @CRLF & _
"But not these lines:" & @CRLF & _
"" & @CRLF & _
"123red warehouse." & @CRLF & _
"123 green token token etc warehouse. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")