import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?!\\d)(?! ?(?:red|green)).*(\\bwarehouse\\b)";
final String string = "123 warehouse\n"
+ "123 token warehouse.\n"
+ "123token token abc123; etc. - warehouse \n"
+ "123abdc token abc green warehouse \n\n"
+ "But not these lines:\n\n"
+ "123red warehouse.\n"
+ "123 green token token etc warehouse. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}