use strict;
my $str = '123 warehouse
123 token warehouse.
123token token abc123; etc. - warehouse
123abdc token abc green warehouse
But not these lines:
123red warehouse.
123 green token token etc warehouse. ';
my $regex = qr/\d+(?!\d)(?! ?(?:red|green)).*(\bwarehouse\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}