import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( 'li'\\s*:\\s*\\[\\s*'([^']+?)'\n"
+ "| \\s*,\\s*'([^']+?)'(\\s*],?\\s*)?\n"
+ ")\n\n";
final String string = "'li':['item 1','item 2','item 3'],\n"
+ "'li':['item 4','item 5','item 6'],\n"
+ "'li':['item 7','item 8','item 9'], \n"
+ "'li' : [\n"
+ " 'item 3',\n"
+ " 'item 4' ,\n"
+ " 'item 5'\n"
+ " ] ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}