$re = '/( \'li\'\s*:\s*\[\s*\'([^\']+?)\'
| \s*,\s*\'([^\']+?)\'(\s*],?\s*)?
)
/sx';
$str = '\'li\':[\'item 1\',\'item 2\',\'item 3\'],
\'li\':[\'item 4\',\'item 5\',\'item 6\'],
\'li\':[\'item 7\',\'item 8\',\'item 9\'],
\'li\' : [
\'item 3\',
\'item 4\' ,
\'item 5\'
] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);