use strict;
my $str = '\'li\':[\'item 1\',\'item 2\',\'item 3\'],
\'li\':[\'item 4\',\'item 5\',\'item 6\'],
\'li\':[\'item 7\',\'item 8\',\'item 9\'],
\'li\' : [
\'item 3\',
\'item 4\' ,
\'item 5\'
] ';
my $regex = qr/( 'li'\s*:\s*\[\s*'([^']+?)'
| \s*,\s*'([^']+?)'(\s*],?\s*)?
)
/sxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}