re = /( 'li'\s*:\s*\[\s*'([^']+?)'
| \s*,\s*'([^']+?)'(\s*],?\s*)?
)
/x
str = '\'li\':[\'item 1\',\'item 2\',\'item 3\'],
\'li\':[\'item 4\',\'item 5\',\'item 6\'],
\'li\':[\'item 7\',\'item 8\',\'item 9\'],
\'li\' : [
\'item 3\',
\'item 4\' ,
\'item 5\'
] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end