using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{\s*""([^""]+\.(webp|avif|jpg|jpeg|png|gif))""\s*""([^""]+)""(?:\s*(align=""right""))?(?:\s*(width=""\d+"")\s*(height=""\d+""))?\s*\}\}";
string input = @"<div>
{{""https://medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" width=""2002"" height=""3000""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" width=""2002"" height=""3000""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" height=""3000"" width=""2002""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" height=""3000"" width=""2002""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" width=""2002"" height=""3000""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" width=""2002""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" height=""3000""}}
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right""}}
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
{{""/medias/images/uploads/clay-banks-original.webp"" ""Yaquina Head, Newport, États-Unis."" align=""right"" width=""2002"" height=""3000""}}
</div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}