$re = '/\{\{\s*"([^"]+\.(webp|avif|jpg|jpeg|png|gif))"\s*"([^"]+)"(?:\s*(align="right"))?(?:\s*(width="\d+")\s*(height="\d+"))?\s*\}\}/';
$str = '<div>
{{"https://medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" width="2002" height="3000"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" width="2002" height="3000"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" height="3000" width="2002"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." height="3000" width="2002"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" width="2002" height="3000"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" width="2002"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" height="3000"}}
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right"}}
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
{{"/medias/images/uploads/clay-banks-original.webp" "Yaquina Head, Newport, États-Unis." align="right" width="2002" height="3000"}}
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);