import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\s*\"([^\"]+\\.(webp|avif|jpg|jpeg|png|gif))\"\\s*\"([^\"]+)\"(?:\\s*(align=\"right\"))?(?:\\s*(width=\"\\d+\")\\s*(height=\"\\d+\"))?\\s*\\}\\}";
final String string = "<div>\n"
+ "{{\"https://medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" height=\"3000\" width=\"2002\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" height=\"3000\" width=\"2002\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" height=\"3000\"}}\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\"}}\n"
+ " <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>\n"
+ "{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
+ "</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}