import re
regex = re.compile(r"\{\{\s*\"([^\"]+\.(webp|avif|jpg|jpeg|png|gif))\"\s*\"([^\"]+)\"(?:\s*(align=\"right\"))?(?:\s*(width=\"\d+\")\s*(height=\"\d+\"))?\s*\}\}")
test_str = ("<div>\n"
"{{\"https://medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" height=\"3000\" width=\"2002\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" height=\"3000\" width=\"2002\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" height=\"3000\"}}\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\"}}\n"
" <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>\n"
"{{\"/medias/images/uploads/clay-banks-original.webp\" \"Yaquina Head, Newport, États-Unis.\" align=\"right\" width=\"2002\" height=\"3000\"}}\n"
"</div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")