package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:1[0-4]|[0-9])(?:\.\d+)?$`)
var str = `1.123
10.5
11
14.99999
15
15.0000
15.1
25
100.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}