$re = '/^(?:1[0-4]|[0-9])(?:\.\d+)?$/m';
$str = '1.123
10.5
11
14.99999
15
15.0000
15.1
25
100.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);