re = /^(?:1[0-4]|[0-9])(?:\.\d+)?$/m
str = '1.123
10.5
11
14.99999
15
15.0000
15.1
25
100.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end