import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:1[0-4]|[0-9])(?:\\.\\d+)?$";
final String string = "1.123\n"
+ "10.5\n"
+ "11\n"
+ "14.99999\n"
+ "15\n"
+ "15.0000\n"
+ "15.1\n"
+ "25\n"
+ "100.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}