#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{2}-\d{8}$"
Local $sString = "AB-23131313" & @CRLF & _
"DJ-313132312" & @CRLF & _
"DJ-31313231" & @CRLF & _
"DJ-3131323" & @CRLF & _
"DJ-31313231" & @CRLF & _
"D8-31313231" & @CRLF & _
"Df-31332312"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")