import re
regex = re.compile(r"^[A-Z]{2}-\d{8}$", flags=re.MULTILINE)
test_str = ("AB-23131313\n"
"DJ-313132312\n"
"DJ-31313231\n"
"DJ-3131323\n"
"DJ-31313231\n"
"D8-31313231\n"
"Df-31332312")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")