$re = '/^[A-Z]{2}-\d{8}$/m';
$str = 'AB-23131313
DJ-313132312
DJ-31313231
DJ-3131323
DJ-31313231
D8-31313231
Df-31332312';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);