using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{2}-\d{8}$";
string input = @"AB-23131313
DJ-313132312
DJ-31313231
DJ-3131323
DJ-31313231
D8-31313231
Df-31332312";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}