#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(\d+).([^:]+):([^:]+):(.*?)(?:\n\n|\Z)"
Local $sString = "1. Food : Cake : Baked sweet food made from flour, sugar and other ingredients." & @CRLF & _
"" & @CRLF & _
"2. Electronics : Computer : A machine to carry out a computer programming operation." & @CRLF & _
" Computers mainly consists of a CPU, monitor, keyboard and a mouse." & @CRLF & _
"" & @CRLF & _
"3. Automobile : Car : Car is a four wheeled motor vehicle used for transportation."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")