import re
regex = re.compile(r"^(\d+).([^:]+):([^:]+):(.*?)(?:\n\n|\Z)", flags=re.MULTILINE | re.DOTALL)
test_str = ("1. Food : Cake : Baked sweet food made from flour, sugar and other ingredients.\n\n"
"2. Electronics : Computer : A machine to carry out a computer programming operation.\n"
" Computers mainly consists of a CPU, monitor, keyboard and a mouse.\n\n"
"3. Automobile : Car : Car is a four wheeled motor vehicle used for transportation.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")