import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+).([^:]+):([^:]+):(.*?)(?:\\n\\n|\\Z)";
final String string = "1. Food : Cake : Baked sweet food made from flour, sugar and other ingredients.\n\n"
+ "2. Electronics : Computer : A machine to carry out a computer programming operation.\n"
+ " Computers mainly consists of a CPU, monitor, keyboard and a mouse.\n\n"
+ "3. Automobile : Car : Car is a four wheeled motor vehicle used for transportation.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}