import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[:\\d])(?P<hour>\\d+)?(?: *:? *)(?P<minute>\\d+)?";
final String string = "6 :\n"
+ "6:\n"
+ "6\n"
+ ": 6\n"
+ ":6\n"
+ ": 16\n"
+ ":16\n"
+ " 6\n"
+ "15 : 1\n"
+ "15 1\n"
+ ": 15\n"
+ "0 15\n"
+ " : 15\n"
+ " 6 :\n"
+ " 12\n"
+ "input_text = \"entre las 15 : hs -- 16:10 \"\n"
+ "input_text = \"entre las 21 : -- 22\"\n"
+ "input_text = \"entre la 1 30 -- 2 \"\n"
+ "input_text = \"entre la 1 09 h.s. -- 6 : hs.\"\n"
+ "input_text = \"entre la 1:50 -- 6 :\"\n"
+ "input_text = \"entre la 7 59 -- 23 : \"\n"
+ "input_text = \"entre la 10: -- : 10\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}