$re = '/(?=[:\d])(?P<hour>\d+)?(?: *:? *)(?P<minute>\d+)?/m';
$str = '6 :
6:
6
: 6
:6
: 16
:16
6
15 : 1
15 1
: 15
0 15
: 15
6 :
12
input_text = "entre las 15 : hs -- 16:10 "
input_text = "entre las 21 : -- 22"
input_text = "entre la 1 30 -- 2 "
input_text = "entre la 1 09 h.s. -- 6 : hs."
input_text = "entre la 1:50 -- 6 :"
input_text = "entre la 7 59 -- 23 : "
input_text = "entre la 10: -- : 10"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);