use strict;
my $str = '6 :
6:
6
: 6
:6
: 16
:16
6
15 : 1
15 1
: 15
0 15
: 15
6 :
12
input_text = "entre las 15 : hs -- 16:10 "
input_text = "entre las 21 : -- 22"
input_text = "entre la 1 30 -- 2 "
input_text = "entre la 1 09 h.s. -- 6 : hs."
input_text = "entre la 1:50 -- 6 :"
input_text = "entre la 7 59 -- 23 : "
input_text = "entre la 10: -- : 10"';
my $regex = qr/(?=[:\d])(?P<hour>\d+)?(?: *:? *)(?P<minute>\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}