# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=[:\d])(?P<hour>\d+)?(?: *:? *)(?P<minute>\d+)?"
test_str = ("6 :\n"
"6:\n"
"6\n"
": 6\n"
":6\n"
": 16\n"
":16\n"
" 6\n"
"15 : 1\n"
"15 1\n"
": 15\n"
"0 15\n"
" : 15\n"
" 6 :\n"
" 12\n"
"input_text = \"entre las 15 : hs -- 16:10 \"\n"
"input_text = \"entre las 21 : -- 22\"\n"
"input_text = \"entre la 1 30 -- 2 \"\n"
"input_text = \"entre la 1 09 h.s. -- 6 : hs.\"\n"
"input_text = \"entre la 1:50 -- 6 :\"\n"
"input_text = \"entre la 7 59 -- 23 : \"\n"
"input_text = \"entre la 10: -- : 10\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.