const regex = /([^a-zA-Z0-9\s])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^a-zA-Z0-9\\s])', 'gm')
const str = `Player's got to * play! #justsaying`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);