use strict;
my $str = 'Player\'s got to * play! #justsaying';
my $regex = qr/([^a-zA-Z0-9\s])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";