$re = '/([^a-zA-Z0-9\s])/m';
$str = 'Player\'s got to * play! #justsaying';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;