re = /([^a-zA-Z0-9\s])/m
str = 'Player\'s got to * play! #justsaying'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result