re = /^(?![\/\w:]*:[:\/])[\/\w:]*$/m
str = '
/
:id
/:id
/:id/
person/:name/:id/:token_person2/image
person////
////
:::id
person/:/name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end