#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)\s+\(.*\b\)"
Local $sString = "Zwischenschalter & Einbauschalter (16 Produkte)" & @CRLF & _
"Zwingen (101 Produkte)" & @CRLF & _
"Zuschnittplatten (241 Produkte)" & @CRLF & _
"Zurrösen (2 Produkte)" & @CRLF & _
"Zulaufschläuche & Ablaufschläuche (10 Produkte)" & @CRLF & _
"Zündkerzen (26 Produkte)" & @CRLF & _
"Zuckerhutfichten (3 Produkte)" & @CRLF & _
"Zubehör für Wassersport (43 Produkte)" & @CRLF & _
"Zubehör für Regenwassernutzung (73 Produkte)" & @CRLF & _
"Zubehör für Pflanzgefäße (487 Produkte)" & @CRLF & _
"Zubehör für Insektenschutzgitter (23 Produkte)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")