use strict;
my $str = 'Zwischenschalter & Einbauschalter (16 Produkte)
Zwingen (101 Produkte)
Zuschnittplatten (241 Produkte)
Zurrösen (2 Produkte)
Zulaufschläuche & Ablaufschläuche (10 Produkte)
Zündkerzen (26 Produkte)
Zuckerhutfichten (3 Produkte)
Zubehör für Wassersport (43 Produkte)
Zubehör für Regenwassernutzung (73 Produkte)
Zubehör für Pflanzgefäße (487 Produkte)
Zubehör für Insektenschutzgitter (23 Produkte)
';
my $regex = qr/\s+\(.*\b\)/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}