$re = '/\s+\(.*\b\)/mu';
$str = 'Zwischenschalter & Einbauschalter (16 Produkte)
Zwingen (101 Produkte)
Zuschnittplatten (241 Produkte)
Zurrösen (2 Produkte)
Zulaufschläuche & Ablaufschläuche (10 Produkte)
Zündkerzen (26 Produkte)
Zuckerhutfichten (3 Produkte)
Zubehör für Wassersport (43 Produkte)
Zubehör für Regenwassernutzung (73 Produkte)
Zubehör für Pflanzgefäße (487 Produkte)
Zubehör für Insektenschutzgitter (23 Produkte)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);