package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+\(.*\b\)`)
var str = `Zwischenschalter & Einbauschalter (16 Produkte)
Zwingen (101 Produkte)
Zuschnittplatten (241 Produkte)
Zurrösen (2 Produkte)
Zulaufschläuche & Ablaufschläuche (10 Produkte)
Zündkerzen (26 Produkte)
Zuckerhutfichten (3 Produkte)
Zubehör für Wassersport (43 Produkte)
Zubehör für Regenwassernutzung (73 Produkte)
Zubehör für Pflanzgefäße (487 Produkte)
Zubehör für Insektenschutzgitter (23 Produkte)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}