#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""name"(?:(?!"name")(.|\n))+]*"name"(?:(?!"name")(.|\n))+]*"name":[ ]*"([^"]*)"
Local $sString = "{" & @CRLF & _
" "friends": [" & @CRLF & _
" { "name": "anny"}, { "name": "steve"}," & @CRLF & _
" { "name":"joe" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")