const regex = /"name"(?:(?!"name")(.|\n))+]*"name"(?:(?!"name")(.|\n))+]*"name":[ ]*"([^"]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"name"(?:(?!"name")(.|\\n))+]*"name"(?:(?!"name")(.|\\n))+]*"name":[ ]*"([^"]*)', '')
const str = `{
"friends": [
{ "name": "anny"}, { "name": "steve"},
{ "name":"joe" }
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}