$re = '/"name"(?:(?!"name")(.|\n))+]*"name"(?:(?!"name")(.|\n))+]*"name":[ ]*"([^"]*)/';
$str = '{
"friends": [
{ "name": "anny"}, { "name": "steve"},
{ "name":"joe" }
]
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);