re = /"name"(?:(?!"name")(.|\n))+]*"name"(?:(?!"name")(.|\n))+]*"name":[ ]*"([^"]*)/
str = '{
"friends": [
{ "name": "anny"}, { "name": "steve"},
{ "name":"joe" }
]
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end