#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((\n)\2{2})\2+"
Local $sString = "Some text" & @CRLF & _
"" & @CRLF & _
"Text with more new lines" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Radar," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"thhth" & @CRLF & _
"th" & @CRLF & _
"th" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"th" & @CRLF & _
"th" & @CRLF & _
"" & @CRLF & _
"ßß" & @CRLF & _
"" & @CRLF & _
"$1 always contains 3 newlines for the limited replacement when applicable"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")