using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\n)\2{2})\2+";
string input = @"Some text
Text with more new lines
Radar,
thhth
th
th
th
th
ßß
$1 always contains 3 newlines for the limited replacement when applicable";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}