re = /((\n)\2{2})\2+/
str = 'Some text
Text with more new lines
Radar,
thhth
th
th
th
th
ßß
$1 always contains 3 newlines for the limited replacement when applicable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end