$re = '/((\n)\2{2})\2+/';
$str = 'Some text
Text with more new lines
Radar,
thhth
th
th
th
th
ßß
$1 always contains 3 newlines for the limited replacement when applicable';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);